
 
GoldServ Monitor 

 
An AuSIM GoldServ™ Server Guide 

 
 
 

User’s Guide and Reference 
 

v1.925 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Copyright © 2004 AuSIM, Inc. All rights Reserved 



TABLE OF CONTENTS 
 
GoldServ Monitor................................................................................................1 
An AuSIM GoldServ™ Server Guide ....................................................................1 
User’s Guide and Reference ..............................................................................1 
Copyright © 2004 AuSIM, Inc. All rights Reserved ...............................................1 
TABLE OF CONTENTS .......................................................................................2 
Chapter 1 Introduction......................................................................................6 

1.1 Overview.................................................................................................6 
1.2 Background ............................................................................................6 
1.3 Setup ......................................................................................................6 

Chapter 2 Getting Started ................................................................................8 
2.1 Launching the GoldServ window ............................................................8 
2.2 The GoldServ Window Display ...............................................................8 
2.3 Connecting a Client ................................................................................9 
2.4 Monitoring the Simulation Configuration...............................................10 
2.5 Alternate Views of the Acoustic Simulation...........................................11 

2.5.1 Main View......................................................................................11 
2.5.2 Path View ......................................................................................13 
2.5.3 Event View ....................................................................................14 
2.5.4 Atron Status...................................................................................16 

Chapter 3 Menu, ToolBar, and Display Reference.........................................17 
3.1 Menu Selections ...................................................................................17 

3.1.1 File.................................................................................................17 
3.1.2 Edit ................................................................................................17 
3.1.3 View...............................................................................................17 
3.1.4 System ..........................................................................................18 
3.1.5 Format ...........................................................................................19 
3.1.6 Help ...............................................................................................19 

3.2 Toolbar Buttons ....................................................................................20 
3.2.1 Atron Status...................................................................................20 
3.2.2 Main View......................................................................................20 
3.2.3 Path View ......................................................................................21 
3.2.4 Event View ....................................................................................21 
3.2.5 Reset GoldServ .............................................................................21 
3.2.6 About GoldServ .............................................................................22 

3.3 Main View Panels .................................................................................22 
3.3.1 Listener Panel ...............................................................................23 
3.3.1.1 Listener ID .................................................................................23 
3.3.1.2 X ................................................................................................24 
3.3.1.3 Y ................................................................................................24 
3.3.1.4 Z.................................................................................................24 
3.3.1.5 Yaw............................................................................................24 
3.3.1.6 Pitch...........................................................................................24 
3.3.1.7 Roll.............................................................................................24 
3.3.1.8 Gain ...........................................................................................25 



3.3.1.9 AHM...........................................................................................25 
3.3.1.10 Output Device ............................................................................25 
3.3.1.11 Equalization Filter ......................................................................25 
3.3.1.12 Update .......................................................................................25 
3.3.1.13 Level of Left Channel .................................................................25 
3.3.1.14 Level of Right Channel...............................................................26 
3.3.1.15 Clipped.......................................................................................26 
3.3.2 Sound Source Panel......................................................................26 
3.3.2.1 Source ID...................................................................................26 
3.3.2.2 X ................................................................................................26 
3.3.2.3 Y ................................................................................................27 
3.3.2.4 Z.................................................................................................27 
3.3.2.5 Yaw............................................................................................27 
3.3.2.6 Pitch...........................................................................................27 
3.3.2.7 Roll.............................................................................................28 
3.3.2.8 Gain ...........................................................................................28 
3.3.2.9 Play State ..................................................................................28 
3.3.2.10 Signal.........................................................................................28 
3.3.2.11 Loop Count ................................................................................28 
3.3.2.12 Absolute Position .......................................................................28 
3.3.2.13 Loop Position .............................................................................29 
3.3.2.14 Loop Number .............................................................................29 
3.3.2.15 Update .......................................................................................29 
3.3.2.16 Level ..........................................................................................29 
3.3.2.17 Skipped......................................................................................29 
3.3.2.18 Interpolation ...............................................................................29 
3.3.2.19 Delay Line Length ......................................................................29 
3.3.3 Input Audio Signal Panel ...............................................................30 
3.3.3.1 Short Name................................................................................30 
3.3.3.2 Full Name ..................................................................................30 
3.3.3.3 Channels....................................................................................30 
3.3.3.4 Sample Rate ..............................................................................30 
3.3.3.5 Sample Type..............................................................................30 
3.3.3.6 Length........................................................................................31 
3.3.3.7 Number of Readers....................................................................31 
3.3.3.8 Number of WavFt’s ....................................................................31 
3.3.3.9 WavFt Channels ........................................................................31 
3.3.3.10 WavFt Persistance.....................................................................31 
3.3.3.11 WavFt Interpolation....................................................................31 
3.3.3.12 Create String..............................................................................31 

3.4 Path View Panels .................................................................................32 
3.4.1 Path Panel.....................................................................................32 
3.4.1.1 Path ID.......................................................................................33 
3.4.1.2 Signal.........................................................................................33 
3.4.1.3 Gain Left ....................................................................................33 
3.4.1.4 Gain Right ..................................................................................33 



3.4.1.5 Time Delay Left..........................................................................33 
3.4.1.6 Time Delay Right .......................................................................33 
3.4.1.7 ITD.............................................................................................34 
3.4.1.8 Time Origin ................................................................................34 
3.4.1.9 Pre Level....................................................................................34 
3.4.1.10 Filter Level, Left Channel ...........................................................34 
3.4.1.11 Filter Level, Right Channel.........................................................34 
3.4.1.12 Post Level, Left Channel............................................................34 
3.4.1.13 Post Level, Right Channel .........................................................34 
3.4.2 Location (Path-specific) Panel.......................................................35 
3.4.2.1 Location .....................................................................................36 
3.4.2.2 X ................................................................................................36 
3.4.2.3 Y ................................................................................................36 
3.4.2.4 Z.................................................................................................36 
3.4.2.5 Yaw............................................................................................37 
3.4.2.6 Pitch...........................................................................................37 
3.4.2.7 Roll.............................................................................................37 
3.4.3 Model (Path-specific) Panel...........................................................37 
3.4.3.1 Model Type ................................................................................38 
3.4.3.2 Model Name ..............................................................................38 
3.4.3.3 Global Enable ............................................................................38 
3.4.3.4 Model Enable.............................................................................38 
3.4.3.5 Gain, Left Channel .....................................................................38 
3.4.3.6 Gain, Right Channel...................................................................39 
3.4.3.7 Delay, Left Channel ...................................................................39 
3.4.3.8 Delay, Right Channel .................................................................39 
3.4.3.9 Filters .........................................................................................39 
3.4.3.10 Integer Attributes........................................................................39 
3.4.3.11 Double Attributes .......................................................................39 
3.4.3.12 Double Array Attributes..............................................................39 
3.4.3.13 String Attributes .........................................................................40 

3.5 Event View Panels................................................................................40 
3.5.1 Clock Panel ...................................................................................40 
3.5.1.1 Clock..........................................................................................41 
3.5.1.2 Current Time..............................................................................41 
3.5.1.3 Number of Events ......................................................................41 
3.5.1.4 Relative Queue ..........................................................................41 
3.5.1.5 Immediate Queue ......................................................................41 
3.5.1.6 Running .....................................................................................41 
3.5.2 Events Panel .................................................................................42 
3.5.2.1 Event Time.................................................................................42 
3.5.2.2 Event Type.................................................................................42 
3.5.2.3 Object ID....................................................................................42 
3.5.2.4 Object Name..............................................................................42 
3.5.2.5 Argument 1 ................................................................................42 
3.5.2.6 Argument 2 ................................................................................43 



3.6 Status Bar Fields ..................................................................................43 
3.6.1 Status Message.............................................................................43 
3.6.2 Skipped Buffers Counter ...............................................................43 
3.6.3 Clock .............................................................................................43 
3.6.4 RS-232 Serial Port Transport Mechanism .....................................44 
3.6.5 RPC Ethernet Transport Mechanism.............................................44 
3.6.6 USB 2.0 Transport Mechanism .....................................................44 
3.6.7 TCP Ethernet Transport Mechanism .............................................44 

 
 
 



 

 Page 6 

Chapter 1 Introduction 
 
1.1 Overview 
 
The purpose of this document is to serve as a user’s guide, tutorial, and general reference for the 
monitor interface for the software package “GoldServ™” such as can currently be found on an 
AuSIM GoldMiner™ system, or any other system in AuSIM’s GoldSeries™ product line. 
Currently, the GoldServ technology is packaged as an application that runs in the foreground of a 
Windows session, displaying a window that allows read-only monitoring of the execution of this 
application.  Future versions of the GoldServ package, however, are expected to run in the 
background as a Windows service, in which case the monitor will be a separate application that 
will display information about the GoldServ service execution in the same manner.  This 
document is intended to apply to both incarnations of GoldServ technology.  
 
1.2 Background 
 
The GoldServ application is the server portion of the client-server audio simulation system 
designed by AuSIM to implement AuSIM3D technology.  The GoldServ application is specifically 
an executable software file the runs on a GoldServer computing system, which is physically 
assembled and sold by AuSIM.   
 
The GoldServ server application is controlled by a separate client application, which can be 
located on a different physical system.  The client application can be written based on an open 
API and compiled into an executable by the end user of the system, although a number of 
example and demo client applications come bundled with the GoldServer system upon initial 
delivery.  The client application can communicate with the server application by any of several 
different physical mechanisms, including an RS-232 serial cable, a USB connection, and an 
Ethernet network using RPC or TCP transport protocols.  When the server application receives 
commands from a client application via one of these physical connections, it responds by 
producing audio or changing the audio currently being produced in the directed way.  
 
Audio produced by the GoldServ is a binaural pair that consists of a mix of input audio signals 
filtered as directed by commands from the client application.  The audio input signals to the 
GoldServ include both “live” physical inputs to the GoldServer along with pre-recorded audio files 
that have been stored on a physical drive on the GoldServer system.  The filtering applied by the 
GoldServ is based upon mathematical models that together represent a virtual environment.  
These models include mathematical descriptions of Sound Sources, an acoustic Environment, 
and one or more Listeners.  Application of these filters as directed by a client application causes 
the GoldServ application to generate a binaural pair that renders audio input sources in a virtual 
acoustic space to a listener.   
 
The purpose of the GoldServ monitor window is to display the input audio signals the system is 
aware of, the rendering instructions that have been sent by the client application, and the 
resulting state of the key parameters that describe the virtual acoustic space being rendered.  
This chiefly assists client application developers with verifying that the instructions sent from the 
client are creating the desired virtual acoustic space for each listener.  A secondary purpose 
would be for an end user to verify what is heard from the system with a text-based visual 
confirmation, to aid in comprehension of the content.   
 
1.3 Setup 
 
The GoldServ application may be triggered in any of the ways that any executable may be 
launched from a Windows or DOS-console interface.  In fact, GoldServer systems are delivered 
configured to automatically activate a GoldServ executable file upon system boot.  However, the 
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most common way to launch a GoldServ window while performing development or system testing 
is probably through a desktop or menu shortcut.   
 
When the GoldServ is launched through a shortcut, command line parameters may be specified 
that direct that instance of the GoldServ to listen to a specific port for client commands.  This 
allows multiple instances of a GoldServ server to run simultaneously on a GoldServer system, 
with each application instance listening only to its assigned ports for control instructions.  Help in 
use of the command line arguments can be had by typing /? after the executable name in a DOS-
console window, or from other GoldServ user guides in this series.   
 
Once a GoldServ window has been launched using one of the methods above, it is automatically 
in a state where it can begin receiving commands from a client.  At this point, a client can be 
launched, either on the same system, or on a different system with an appropriate physical 
connection mechanism, and the GoldServ monitor will begin to display its state as it responds to 
client commands. 
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Chapter 2 Getting Started 
 
The GoldServ application can be launched by double-clicking on the GoldServ.exe icon or on a 
shortcut to this application.  This file is generally stored in the AuSIM3D\bin directory.  Shortcuts 
to the file on a GoldServer system are generally found 1) on the desktop, 2) on the AuSIM 
submenu accessed from the “start” button, and 3) in the Startup folder for the “goldminer” user 
account.  These shortcuts have typically been pre-configured to direct the GoldServ to monitor 
one or more of the physically ports on the system.  The number of the port being monitored is 
typically included in the shortcut name for ease of use.   
 
2.1 Launching the GoldServ window 
 
The first step in rendering an acoustic workspace is to open and initialize a GoldServ window.  
Select “GoldServ: COM1” from the desktop or from the Start/AuSIM submenu.  A GoldServ 
instance that is initialized and listening to serial port 1 should be displayed within less than a 
second, as shown in Figure 1 below. 

 

 
Figure 1 - Initial Screen 

 
2.2 The GoldServ Window Display 
 
There are a number of types of data and interactive controls displayed in this window.  The title 
bar at the top shows the name and version number of the executing application, along with the 
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names and numbers of the data ports this instance of the application is monitoring for control 
commands, as shown in Figure 2 below.   
 

 
Figure 2 - Title Bar 

 

Below the title bar are a set of pull-down menus, which mainly control what information is 
displayed and how it is displayed, but also allow for a few minor modifications of the simulation 
parameters themselves.  The menu bar is shown in Figure 3 below: 
 

 
Figure 3 - Menu Bar 

 

Below the menus are the toolbar buttons, which provide more convenient access to a few of the 
most often used menu items.  The tool bar is shown in Figure 4 below: 

 

 
Figure 4 - Toolbar Buttons 

Below the toolbar buttons are the primary data display panels which show continuously-updated 
simulation parameters during rendering.  An example of a data display panel is show in Figure 5 
below: 

 

 
Figure 5 - Data Display Panel 

 

At the bottom of the window is the status bar, which displays several useful monitors of low-level 
system status.  The status bar is shown in Figure 6 below: 
 

 
Figure 6 - Status Bar 

 
Chapter 3 of this document provides a detailed explanation of the purpose of each menu item and 
toolbar button and how they can be used to manage the display, along with detailed descriptions 
of each display field on the main panels and on the status bar.   
 
 
2.3 Connecting a Client 
 



 

 Page 10 

The GoldServ server application is controlled by separate client applications, which are typically 
located on a different physical system.  In theory, a client can be run on the GoldServ system 
itself, assuming the appropriate physical connections and settings, but this is not recommended, 
as it will degrade system performance.  A number of example client applications are bundled with 
each GoldServer upon initial shipment, but custom clients can also be written based on an open 
API known as CRE_TRON.  
 
To install example client applications on a client system, an installation program called 
“AuSIM_Win32_Client_Installer.exe” can be found on the GoldServer in the folder 
D:\AuSIM3D\Client.  This installer program should be copied via a disk or network to the client 
computer, and launched by double-clicking on it with a mouse or pointing device.  The client 
installation program will install the example client applications by default to a folder named 
“AuSIM” that it will create in the “Programs” folder, but a different folder can be specified at 
installation time if desired. 
 
This installation program will install such standard example clients as Nordjorvik, 
RendographClient, GoldTools, and Theodolite, among others.  Detailed reference manuals/user 
guides for operating these applications are available from AuSIM as separate documents.     
 
The client application can communicate with the server application by any of several different 
physical mechanisms, including an RS-232 serial cable, a USB connection, and an Ethernet 
network using RPC or TCP transport protocols.  To use a serial cable, one end should be 
connected to a serial port on the client system and the other end should be connected to a serial 
port on the GoldServer.  On the client system, the serial cable should be connected to the serial 
port number that matches the first digit of the TRONCOM environment variable, which by default 
is set to “1@1152”, which specifies COM1 as the sending port.  On the GoldServer system, the 
serial cable should be connected to serial port listed in the server shortcut name or also in the 
GoldServ window title bar.   
 
After a physical connection has been completed, and the GoldServ application has been 
launched, an example client such as Nordjorvik. RendographClient, GoldTools, or Theodolite can 
be used to initialize the server and launch an acoustic simulation. 
 
 
2.4 Monitoring the Simulation Configuration 
 
After a client application has been started and the server initialization step has been completed, 
the GoldServ window can be viewed to monitor the effect that the client control commands are 
having on the GoldServ rendering the simulation.  However, it is recommended that this window 
be minimized during serious GoldServ operation to maximize performance. 
 
When an acoustic simulation has been launched, at least one row of data should appear on the 
top panel, representing information pertaining to the listener(s) defined by the client application.  
Also, at least one row of data should appear on the middle panel, representing information 
pertaining to the sound source(s) defined by the client.  Finally, at least one row of data should 
appear on the bottom panel, representing information pertaining to the input audio signal(s) 
assigned to each sound source.  An input audio signal can be either a physical input channel 
such as can be found on an MME or ASIO input device, or it can be an audio file in the .WAV 
format stored on the hard drive of the GoldServer.  Figure 7 shows the monitor window after a 
simple simulation of one listener and one sound source has been launched by a client:   
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Figure 7 - Simple Simulation Launched 

 
The information pertaining to each listener, sound source, and signal should appear to be 
continuously updated as it is changed by the client application.  Also, whenever the client 
application adds or deletes listeners, sound sources, or signals, new rows of data should appear 
or disappear from the main display panels. 
 
2.5 Alternate Views of the Acoustic Simulation 
 
Although the 3 main display panels described above are displayed by default when the GoldServ 
monitor opens, there are other display tables that are available for viewing at any time.  These 
views can be activated with the four left-most toolbar buttons.  The following sections provide 
summary descriptions of each of the available view configurations.  (More detailed descriptions of 
the data available in these views can be found in Chapter 3.) 
 
2.5.1 Main View 

 
The “Main View” is defined to be the set of Listener, Sound Source, and Input Audio Signal 
display panels that are displayed top-to-bottom when the GoldServ monitor window is first 
opened.  This view can also be activated by selecting “Main View” from the “View” menu or 
clicking with the mouse or pointing device on the “Main View” toolbar button, which is the second 
button from the left, and marked with a symbol of a listener surrounded by a few sound sources – 
see Figure 8 below. 
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Figure 8 - Main View via Menu or Toolbar Button 

 
The top panel in this view displays information pertaining to the listeners in the acoustic 
simulation – see Figure 9 below. Each row of data corresponds to a different listener in the 
simulation, and there can be one or more listeners at any given time.  Each column corresponds 
to a listener attribute, and the columns contain data such as listener number, position, orientation, 
gain, and AHM and EQ filters used. 
 

 
Figure 9 - Listener Panel 

 
The middle panel in this view displays information pertaining to the sound sources in the acoustic 
simulation – see Figure 10 below. Each row of data corresponds to a different sound source in 
the simulation, and there can be one or more sound sources defined at any given time.  Each 
column corresponds to a sound source attribute, and the columns contain data such as sound 
source number, position, orientation, gain, play state and assigned signal. 
 

 
Figure 10 - Sound Source Panel 

 
 
The bottom panel in this view displays information pertaining to the audio input signals used by 
the sound sources in the acoustic simulation – see Figure 11 below. Each row of data 
corresponds to a different physical input channel or wave file, and there can be one or more 
audio input signals defined at any given time.  Each column corresponds to an audio input signal 
attribute, and the columns contain data such as short and long name, number of channels in the 
signal, sample rate, and sample type. 
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Figure 11 - Input Signal Panel 

 
2.5.2 Path View 
 
The “Path View” is defined to be the set of Path, Path Location, and Path Model display panels 
that are displayed top-to-bottom.  This view can be activated by selecting “Path View” from the 
“View” menu or clicking with the mouse or pointing device on the “Path View” toolbar button, 
which is the third button from the left, and marked with a symbol of a listener surrounded by a few 
sound sources, with path lines extending from the sound sources to the listener – see Figure 12 
below. 

 

 
Figure 12 - Path View via Menu or Toolbar Button 

 
The top panel in this view displays information pertaining to the individual audio propagation 
paths from each sound source to each listener – see Figure 13 below.  Each row of data 
corresponds to a different path from a sound source to a listener in the simulation, and so the 
number of paths defined at any given time will be the number of sound sources multiplied by the 
number of listeners.  Each column corresponds to a path attribute, and the columns contain data 
such as path number, signal, left ear gain, right ear gain, left ear time delay, right ear time delay, 
and ITD.   

 

 
Figure 13 - Path Panel 
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The middle panel in this view displays information pertaining to the locations of each audio 
propagation path – see Figure 14 below.  The data displayed on this panel pertains to the path 
that has been selected in the top panel with the mouse or pointing device.  Each column 
corresponds to a path location attribute, and the columns contain data such as path position and 
orientation information.  

 

 
Figure 14 - Location Panel 

 
The bottom panel in this view displays information pertaining to the mathematical models used to 
process each audio propagation path – see Figure 15 below.  The data displayed on this panel 
pertains to the path that has been selected in the top panel with the mouse or pointing device.  
Each row of data corresponds to a different mathematical model used for the selected path.  
Each column corresponds to a model attribute, and the columns contain data such as model 
name, model type, left ear gain from the model, right ear gain from the model, and model filter 
description.  

 

 
Figure 15 - Model Panel 

 
2.5.3 Event View 
 
The “Event View” is defined to be the set of Clock and Event display panels that are displayed 
top-to-bottom.  This view can be activated by selecting “Event View” from the “View” menu or 
clicking with the mouse or pointing device on the “Event View” toolbar button, which is the fourth 
button from the left, and marked with a symbol of what appears to be an image frame from a 
movie film – see Figure 16 below. 
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Figure 16 - Event View via Menu or Toolbar Button 

 
The top panel in this view displays information pertaining to audio timeline Clocks – see Figure 17 
below.  Each row of data corresponds to a different clock, or sequence of audio events.  Each 
column corresponds to a clock attribute, and the columns contain data such as clock number, 
clock time, number of defined events, and play state.   

 

 
Figure 17 - Clock Panel 

 
The bottom panel in this view displays information pertaining to the audio events associated to 
each clock – see Figure 18 below.  The event data displayed on this panel pertains to the clock 
that has been selected in the top panel with the mouse or pointing device.  Each row of data 
corresponds to a different event associated with the selected clock.  Each column corresponds to 
an event attribute, and the columns contain data such as event name, event time, event type, and 
others.  

 

 
Figure 18 - Event Panel 
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2.5.4 Atron Status 
 
The Atron status display appears in a separate window from the main window which displays the 
other views.  This window can be opened by selecting “Atron Status” from the View menu or 
clicking with the mouse or pointing device on the “Atron Status” toolbar button, which is the left-
most button, and marked with a symbol of what could be two data ports connected by a physical 
cable – see Figure 19 below.   
 

 
Figure 19 - Atron Status via Menu or Toolbar Button 

 
The data displayed by the Atron Status window – see Figure 20 below – is a running log of every 
command sent by the connected client and received by the GoldServ audio server.  It can be 
used to verify accurate communication between the client and server, as well as to verify that the 
commands received by the server match what the operator intended for the client application to 
send.   Control buttons at the bottom of this window provide features to help manage this data 
stream, including the ability to save the content to a text file for later viewing with a text or 
document editor. 
 

 
Figure 20 - Atron Status Window 

 
This completes a summary of the basic features of the GoldServ monitor.  For additional help in 
understanding the use of the menu selections and toolbar buttons, please see the reference 
guide in Chapter 3. 
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Chapter 3 Menu, ToolBar, and Display Reference 
 
The purpose of this chapter is to serve as a comprehensive reference guide to the various 
interface objects and display field available in the GoldServ monitor window.  The items described 
are grouped by type of object, and ordered by the sequence in which they occur on the GoldServ 
monitor screen from left to right, top to bottom. 
 
3.1 Menu Selections 
 
The GoldServ application contains six menus arranged from left to right across the top of the 
application window below the title bar – see Figure 3 above.  The items on these menus – see 
Figure 21 below – primarily control what information is displayed on the monitor and how it is 
displayed, but they also permit a few minor modifications of the simulation parameters 
themselves. 
 

 
Figure 21 - Application Menus 

 
3.1.1 File 
 
The first menu from the left is the “File” menu.  Its menu items invoke common functions that are 
related to management of the event list files that can be used by the GoldServ application.   
These functions include: 
 

• Load Clock… – This menu item loads a new clock into server memory from the 
specified event list file. 

• Save Clock… – This menu item saves a current clock definition to a specified event 
list file. 

• Exit – This menu item ends execution of the GoldServ application, closing the main 
window and any child windows that might have been open, such as “Atron Status” or 
“About GoldServ”. 

 
3.1.2 Edit 
 
The second menu from the left is the “Edit” menu.  It includes the following functions:  
 

• Undo – This menu item is inactive at this time. 
• Cut – This menu item is inactive at this time. 
• Copy – This menu item is inactive at this time.   
• Paste – This item is inactive at this time. 
 

3.1.3 View 
The third menu from the left is the “View” menu.  Its menu items invoke functions that are related 
to viewing the content of the acoustic simulation being rendered by the GoldServ application.  
These functions include: 
 

• Tool Bar – Selecting this menu item when it is checked causes the checkmark next to 
it to disappear, and the tool bar at the top of the window (below the menu) to be 
hidden from view.  Selecting this item when it is not checked causes a checkmark to 
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appear next to it and the tool bar to be displayed.  The default state for the tool bar 
display is on/displayed. 

• Status Bar – Selecting this menu item when it is checked causes the checkmark next 
to it to disappear, and the status bar at the bottom of the window to be hidden from 
view.  Selecting this item when it is not checked causes a checkmark to appear next 
to it and the status bar to be displayed.  The default state for the status bar display is 
on/displayed. 

• Atron Status – Selecting this menu item when it is unchecked causes a checkmark to 
appear next to it, and the Atron Status window to be opened.  Selecting this item 
when it is checked causes the checkmark next to it to disappear and the Atron Status 
window to be closed.  The default state for the Atron Status window is 
off/undisplayed. 

• Main View – Selecting this menu causes a checkmark to appear next to it, and the 
“Main View”, which is defined to be the set of Listener, Sound Source, and Input 
Audio Signal display panels, to be displayed.  The Path View and Event View are not 
displayed while the Main View is being displayed.   

• Path View – Selecting this menu causes a checkmark to appear next to it, and the 
“Path View”, which is defined to be the set of Path, Path Location, and Path Model 
display panels, to be displayed.  The Main View and Event View are not displayed 
while the Path View is being displayed.   

• Event View – Selecting this menu causes a checkmark to appear next to it, and the 
“Event View”, which is defined to be the set of Clock and Event display panels, to be 
displayed.  The Main View and Path View are not displayed while the Event View is 
being displayed. 

• Reset Skipped – Selection of this menu item resets the counter of the number of 
skipped buffers to zero.  The skipped buffer counter is located on the status bar at 
the bottom of the window, immediately to the right of the status message field.  
(Audio buffers can be skipped when the load placed on the system by client 
commands is momentarily greater than the system capacity, so these occurrences 
are counted and displayed on the status bar.) 

• Reset Clipped – Selection of this menu item resets the counter(s) of the number of 
clipped output audio occurrences to zero.  The clipped audio counter(s) is/are located 
in the right-most column of the listener panel in the Main View.  (Audio signals can be 
clipped when the total gain computed for the output signal to a Listener results in 
signal amplitude that is greater than the allowed maximum value; these occurrences 
are counted and displayed in the clipped output signal field.) 

 
3.1.4 System 
 
The third menu from the left is the “System” menu.  Its menu items modify the parameters of the 
simulation being rendered by the GoldServer system.  These functions include: 
 

• Reset – This menu item resets the GoldServ application to its initial state, removing 
any active simulation objects and closing any open files, in preparation for receiving a 
new set of commands from a client application.   

• Legacy Synchronization – Selecting this menu item when it is checked causes the 
checkmark next to it to disappear, and the Legacy Synchronization Mode to be 
disabled.  Selecting this item when it is not checked causes a checkmark to appear 
next to it and the Legacy Synchronization Mode to be re-enabled.  The default state 
for the Legacy Synchronization Mode is enabled.  It is recommended that Legacy 
Synchronization mode be left enabled as much as possible, as it is currently 
improves reliability/robustness of GoldServ operation. 

• Headphone EQ Enable – Selecting this menu item when it is checked causes the 
checkmark next to it to disappear, and the headphone equalization filtering to be 
suspended.  Selecting this item when it is not checked causes a checkmark to 
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appear next to it and the headphone equalization filtering to be restarted.  The default 
state for the headphone equalization filtering is on. 

• Select EQ File … – This menu item opens a dialog box that enables browsing to and 
selecting an equalization file (.eqf) for use by the GoldServ for headphone 
equalization filtering. 

• Edit Tracker Mappings …– Selecting this menu item opens a dialog box which allows 
tracker devices which have been detected to be connected to the system to be 
assigned to a Listener or to a Sound Source.  Existing assignments can also be 
edited and/or removed. 

 
3.1.5 Format 
 
The fifth menu from the left is the “Format” menu.  Its menu items set options that help format the 
GoldServ text-based information displays.  Data types include: 
 

• Time – One of four possible formats for the display of all time data can be selected: 
o Time Seconds – the times will be displayed as an integer number of seconds 
o Time Samples – the times will be displayed as an integer number of samples 
o Time HH::MM::SEC – hours, minutes, and seconds will be displayed 
o Time HH::MM::SEC.SAMP – hours, minutes, seconds, and samples will be 

displayed 
 

• Angle – One of two possible formats for the display of all angle data can be selected: 
o Angle Degrees – the angles will be displayed in degrees 
o Angle Radians – the angles will be displayed in radians 

 
• Amplitude – One of three possible formats for the display of all amplitude data can be 

selected: 
o Amplitude dB – the amplitudes will be displayed on a decibel scale 
o Amplitude Linear – the amplitudes will be displayed on a linear scale 
o Amplitude Meters – the amplitudes will be displayed on meters 

 
Only one display format for each data type can be active at a time; the active format will be the 
one most recently selected with the mouse or pointing device, and a checkmark will appear on 
the menu next to the selected display format item. 
 
3.1.6 Help 
 
The right-most menu is the “Help” menu.  It currently only has one selectable item: 
 

• About GoldServ… – This menu item opens a window entitled “About GoldServ” – see 
Figure 22 below – displaying the application name, version number, copyright notice, 
and a table of the current values of all the state variables (for debugging purposes).   
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Figure 22 - About GoldServ Window 

 
3.2 Toolbar Buttons 
 
The GoldServ application contains six toolbar buttons arranged from left to right near the top of 
the application window – see Figure 4 above. The first four buttons activate views of the 
simulation data, the fifth resets the GoldServ, and the sixth opens the “About GoldServ” window. 
 
3.2.1 Atron Status 
 
The “Atron Status” toolbar button is the left-most button, and it is marked with a symbol of what 
could be two data ports connected by a physical cable – see Figure 23 below.  When clicked with 
the mouse or pointing device, it opens the Atron Status window, which displays a running log of 
all commands sent by the connected client and received by the GoldServ.  Pressing this button 
has the same effect as selecting “Atron Status” from the “View” menu. 
 

 
Figure 23 - Atron Status Toolbar Button 

 
3.2.2 Main View 
 
The “Main View” toolbar button is the second button from the left, and it is marked with a symbol 
of a listener surrounded by a few sound sources – see Figure 24 below.  When clicked with the 
mouse or pointing device, it opens the “Main View”, which is defined to be the set of Listener, 
Sound Source, and Input Audio Signal display panels.  The Path View and Event View are not 
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displayed while the Main View is being displayed.  Pressing this button has the same effect as 
selecting “Main View” from the “View” menu. 
 

 
Figure 24 - Main View Toolbar Button 

 
3.2.3 Path View 
 
The “Path View” toolbar button is the third button from the left, and it is marked with a symbol of a 
listener surrounded by a few sound sources, with path lines extending from the sound sources to 
the listener – see Figure 25 below.  When clicked with the mouse or pointing device, it opens the 
“Path View”, which is defined to be the set of Path, Path Location, and Path Model display panels.  
The Main View and Event View are not displayed while the Path View is being displayed.  
Pressing this button has the same effect as selecting “Path View” from the “View” menu. 
 

 
Figure 25 - Path View Toolbar Button 

 
3.2.4 Event View 
 
The “Event View” toolbar button is the fourth button from the left, and it is marked with a symbol 
of what appears to be an image frame from a movie film – see Figure 26 below.  When clicked 
with the mouse or pointing device, it opens the “Event View”, which is defined to be the set of 
Clock and Event display panels.  The Main View and Path View are not displayed while the Event 
View is being displayed.  Pressing this button has the same effect as selecting “Event View” from 
the “View” menu. 
 

 
Figure 26 - Event View Toolbar Button 

 
3.2.5 Reset GoldServ 
 
The “Reset GoldServ” toolbar button is the fifth button from the left, and is marked with a small 
yellow exclamation symbol (“!”) – see Figure 27 below.  When pressed, it resets the GoldServ 
application to its initial state (or “reinitializes” it), removing any active simulation objects and 
closing any open files, in preparation for receiving a new set of commands from a client 
application.  Clicking this button with a mouse or pointing device has the same effect as selecting 
“Reset” from the “System” menu.  
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Figure 27 - Reset GoldServ Toolbar Button 

 
3.2.6 About GoldServ 
 
The “About GoldServ” toolbar button is the right-most button, and is marked with a small yellow 
question mark symbol (“?”) – see Figure 28 below.  When clicked with the mouse or pointing 
device, a window is opened entitled “About GoldServ” displaying the application name, version 
number, copyright notice, and a table of the current values of all the state variables (for 
debugging purposes).  Pressing this button has the same effect as selecting “About GoldServ…” 
from the “Help” menu. 
 

 
Figure 28 - About GoldServ Toolbar Button 

 
3.3 Main View Panels 
 
The “Main View” is the default view and consists of three panels or tables of data – see Figure 29 
below.  The “Listener Panel” is the top-most panel or table; the “Sound Source Panel” is the 
middle panel, and the “Input Audio Signal Panel” is the bottom panel.   
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Figure 29 - The Main View 

 
The following subsections describe the information displayed by each panel. 
 
3.3.1 Listener Panel 
 
The top panel on the Main View is the “Listener Panel”.  Each row in the table corresponds to a 
listener in the acoustic simulation, and each of the 15 columns in the table represents a field of 
data pertaining to listeners – see Figure 30 below.     
 

 
Figure 30 - The Listener Panel Fields 

 
The following subsections describe each of these fields and the information each provides about 
the listeners. 
 
3.3.1.1 Listener ID 
 
The first column, entitled “Listener”, displays an index integer number that uniquely identifies 
each listener.  The serial numbering is zero-based, so the first Listener will be “0”, the second 
Listener will be “1”, etc.  This identifying number, also sometimes referred to as the “Listener ID”, 
is used to identify the listener when calls to the cre_tron API are made. 
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3.3.1.2 X 
 
The second column, entitled “X”, displays the X-coordinate (in Cartesian coordinates) of the 
Listener in the simulated acoustic environment.  The default value is zero, but would increase as 
the listener moves forward from his or her default location/orientation.  Likewise, the value would 
decrease as the listener moves backward.  The units of the coordinate system in use are listed 
next to the coordinate; the default unit is centimeters (cm), but other units that the client may 
specify for use include inches (in), feet (ft), meters (m), and millimeters (mm).   
 
3.3.1.3 Y 
 
The third column, entitled “Y”, displays the Y-coordinate (in Cartesian coordinates) of the Listener 
in the simulated acoustic environment.  The default value is zero, but would increase as the 
listener moves to the left from his or her default location/orientation.  Likewise, the value would 
decrease as the listener moves to the right.  The units of the coordinate system in use are listed 
next to the coordinate; the default unit is centimeters (cm), but other units that the client may 
specify for use include inches (in), feet (ft), meters (m), and millimeters (mm).   
 
3.3.1.4 Z 
 
The fourth column, entitled “Z”, displays the Z-coordinate (in Cartesian coordinates) of the 
Listener in the simulated acoustic environment.  The default value is zero, but would increase as 
the listener moves to the vertically upward from his or her default location/orientation.  Likewise, 
the value would decrease as the listener moves downward.  The units of the coordinate system in 
use are listed next to the coordinate; the default unit is centimeters (cm), but other units that the 
client may specify for use include inches (in), feet (ft), meters (m), and millimeters (mm).   
 
3.3.1.5 Yaw 
 
The fifth column, entitled “Yaw”, displays the rotation of the listener’s head about the vertical axis 
in the simulated acoustic environment.  The default value is zero, but would increase as the 
listener rotates his or her head counter-clockwise from his or her default location/orientation.  
Likewise, the value would decrease as the listener rotates his or her head clockwise.   
 
The default units used by the client and displayed by the GoldServ monitor are degrees, which 
are indicated by a degree symbol next to the value, but the display can be changed to radians by 
selecting “Angle Radians” from the “Format” menu. 
 
3.3.1.6 Pitch 
 
The sixth column, entitled “Pitch”, displays the rotation of the listener’s head about the line 
between the listener’s ears, such as would occur if the listener moved to face upward or 
downward.  The default value is zero, but would increase as the listener rotates his or her head to 
face downward from his or her default orientation.  Likewise, the value would decrease as the 
listener rotates his or her head to face less downward and more upward.  
  
The default units used by the client and displayed by the GoldServ monitor are degrees, which 
are indicated by a degree symbol next to the value, but the display can be changed to radians by 
selecting “Angle Radians” from the “Format” menu. 
 
3.3.1.7 Roll 
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The seventh column, entitled “Roll”, displays the rotation of the listener’s head about the line from 
the nose to the back of the head, such as would occur if the listener leaned his head toward one 
of his or her shoulders.  The default value is zero, but would increase as the listener leans his or 
her head away from the default orientation to bring the right ear closer to the right shoulder.  
Likewise, the value would decrease as the listener leans his or her head to bring the left ear 
closer to the left shoulder.   
 
The default units used by the client and displayed by the GoldServ monitor are degrees, which 
are indicated by a degree symbol next to the value, but the display can be changed to radians by 
selecting “Angle Radians” from the “Format” menu. 
 
3.3.1.8 Gain 
 
The eighth column, entitled “Gain”, displays Gain specified by the client for the specified listener.  
The default value is zero, and the units are decibels by default, but the display can be changed to 
linear units or meters by selecting one of these options from the “Format” menu.  A setting of zero 
would not cause the listener model to affect the overall gain.  Positive values will add that many 
decibels to the overall gain for that specific listener, while negative values will attenuate that many 
decibels from the overall gain. 
 
3.3.1.9 AHM 
 
The ninth column, entitled “AHM”, displays the name of the default built-in Acoustic Head Map 
definition selected or a pre-saved Acoustic Head Map file name selected to filter the signal for the 
specified listener with an individual Head-Related Transfer Function (HRTF).  A common 
standard for naming AHM files is to let the first three letters specify the initials of the individual 
from whom the AHM was measured, and to let the last two digits, if they are present, specify the 
sample rate in kHz.  This standard is often followed for AuSIM-supplied AHM’s. 
 
3.3.1.10 Output Device 
 
The tenth column, entitled “Out Device”, displays the name of the output device that has been 
selected to receive the specified listener’s left and right output signals or binaural mix.   
 
3.3.1.11 Equalization Filter 
 
The eleventh column, entitled “Eq Filter”, displays the name of the file containing the equalization 
filter specified for the analog output display device, such as headphones or nearphones.  These 
can be specified either by a client application or from an environment variable on the GoldServer.  
If the environment variable has not been set and the client hasn’t specified a name, no 
equalization filter will be used, and this field will remain blank. 
 
3.3.1.12 Update 
 
The twelfth column, entitled “Update”, displays the frequency in times per second with which the 
location of the listener is updated via client update commands and/or server side tracking. 
 
3.3.1.13 Level of Left Channel 
 
The thirteenth column, entitled “Level L”, displays the signal level, in decibels by default, of the 
left-ear output channel after being processed by the Output Model, but before clipping detection. 
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3.3.1.14 Level of Right Channel 
 
The fourteenth column, entitled “Level R”, displays the signal level, in decibels by default, of the 
right-ear output channel after being processed by the Output Model, but before clipping detection. 
 
3.3.1.15 Clipped 
 
The fifteenth column, entitled “Clipped”, displays a running counter for the number of left and right 
channel output audio signal sample blocks for which any clipping occurred for that listener.  Audio 
signals are automatically clipped by the system when the total gain computed for the output 
signal to a Listener results in signal amplitude that is greater than the allowed maximum value. 
 
3.3.2 Sound Source Panel 
 
The middle panel on the Main View is the “Sound Source Panel”.  Each row in the table 
corresponds to a sound source in the acoustic simulation, and each of the 19 columns in the table 
represents a field of data pertaining to sound sources – see Figure 31 below.   
 
 

 
Figure 31 - The Sound Source Panel Fields 

 
The following subsections describe each of these fields and the information each provides about 
the sound sources.   
 
3.3.2.1 Source ID 
 
The first column, entitled “Source”, displays an index integer number that uniquely identifies each 
sound source.  The serial numbering is zero-based, so the first sound source will be “0”, the 
second sound source will be “1”, etc.  This identifying number, also sometimes referred to as the 
“Source ID”, is used to identify the source when calls to the cre_tron API are made. 
 
3.3.2.2 X 
 
The second column, entitled “X”, displays the X-coordinate (in Cartesian coordinates) of the 
Source in the simulated acoustic environment.  A positive X value corresponds to positions in 
front of the default location/orientation of the listener, and increasing values of X represent 
locations further away from the listener.  Negative X values correspond to positions in back of the 
default location/orientation of the listener. 
 
The default value is typically non-zero, but it is automatically generated to provide reasonable 
separation between the sources.  Thus, the default location of each source in a simulation is 
unique to the simulation, and the default coordinates assigned to the set of sources varies based 
on how many sources were initialized.  Of course, this coordinate value can be changed by the 
client at any time, before or after initialization. 
 
The units of the coordinate system in use are listed next to the coordinate; the default unit is 
centimeters (cm), but other units that the client may specify for use include inches (in), feet (ft), 
meters (m), and millimeters (mm).   
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3.3.2.3 Y 
 
The third column, entitled “Y”, displays the Y-coordinate (in Cartesian coordinates) of the Source 
in the simulated acoustic environment.  A positive Y value corresponds to positions to the left of 
the default location/orientation of the listener, and increasing values of Y represent locations 
further away from the listener.  Negative Y values correspond to positions to the right of the 
default location/orientation of the listener. 
 
The default value is typically non-zero when multiple sources are present, but values are 
automatically generated to provide reasonable separation between the sources.  Thus, the 
default location of each source in a simulation is unique to the simulation, and the default 
coordinates assigned to the set of sources varies based on how many sources were initialized.  
Of course, this coordinate value can be changed by the client at any time, before or after 
initialization. 
 
The units of the coordinate system in use are listed next to the coordinate; the default unit is 
centimeters (cm), but other units that the client may specify for use include inches (in), feet (ft), 
meters (m), and millimeters (mm).   
 
3.3.2.4 Z 
 
The fourth column, entitled “Z”, displays the Z-coordinate (in Cartesian coordinates) of the Source 
in the simulated acoustic environment.  A positive Z value corresponds to positions above the 
default location/orientation of the listener, and increasing values of Z represent locations higher 
above the listener.  Negative Z values correspond to positions below the default 
location/orientation of the listener. 
 
The default value of Z is typically zero.  The units of the coordinate system in use are listed next 
to the coordinate; the default unit is centimeters (cm), but other units that the client may specify 
for use include inches (in), feet (ft), meters (m), and millimeters (mm).   
 
3.3.2.5 Yaw 
 
The fifth column, entitled “Yaw”, displays the rotation of directional source’s primary propagation 
axis about the vertical axis in the simulated acoustic environment.  The default value is -180 
degrees, representing an orientation of facing back toward the negative X direction, but will 
increase as the source rotates counter-clockwise from the default location/orientation, and it will 
becomes zero when facing the positive X direction.  Likewise, the value will decrease as the 
source rotates clockwise. 
 
The default units used by the client and displayed by the GoldServ monitor are degrees, but the 
display can be changed to radians by selecting “Angle Radians” from the “Format” menu. 
 
3.3.2.6 Pitch 
 
The sixth column, entitled “Pitch”, displays the rotation of the source about the line in the 
horizontal plane perpendicular to the primary propagation axis, such as would occur if the 
source’s primary propagation direction was moved to point upward or downward.  The default 
value is zero, but will increase as the source is rotated to point downward from the default 
orientation of level with respect to the horizontal plane.  Likewise, the value would decrease as 
the source is rotated to point less downward and more upward. 
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The default units used by the client and displayed by the GoldServ monitor are degrees, but the 
display can be changed to radians by selecting “Angle Radians” from the “Format” menu. 
 
3.3.2.7 Roll 
 
The seventh column, entitled “Roll”, displays the rotation of the source about the primary 
propagation direction axis.  The default value is zero, but non-zero values will not change the 
emission pattern from the sound source, because emission is defined by the Source Model to be 
radially symmetric around this axis.  The default units used by the client and displayed by the 
GoldServ monitor are degrees, but the display can be changed to radians by selecting “Angle 
Radians” from the “Format” menu. 
 
3.3.2.8 Gain 
 
The eighth column, entitled “Gain”, displays Gain specified by the client for the specified sound 
source.  The default value is zero, and the units are decibels by default, but the display can be 
changed to linear units or meters by selecting one of these options from the “Format” menu.  A 
setting of zero would not cause the sound source model to affect the overall gain.  Positive values 
will increase the overall gain for that specific sound source, while negative values will attenuate 
the gain. 
 
3.3.2.9 Play State 
 
The ninth column, entitled “Play State”, displays the state of the signal assigned to each sound 
source with respect to whether it is playing, paused or stopped.  Its specific values can be one of 
the following states: 
 

o “Paused” – the source is in paused or stopped state where it is not playing 
o “Playing” – the source is in a state of playing and is generating sound 
o “Past Loop” – the source is in state of playing, but the assigned signal has reached the 

end of its definition and there are no more samples to play to generate further sound 
 
3.3.2.10 Signal 
 
The tenth column, entitled “Signal”, displays the name of the input audio signal assigned to the 
specified sound source.  This signal name can be looked up in the “Short Name” column of the 
Input Signal table below to find more information pertaining to this input audio signal.  For a wave 
file, this will be the file name without the full path or file extension.  For a physical input channel, 
this will be the physical channel number. 
 
3.3.2.11 Loop Count 
 
The eleventh column, entitled “Loop Count”, displays the number of times the input audio signal is 
scheduled to be repeated on this sound source.  Possible values are zero when the loop mode is 
off, in which case “No Loop” would be displayed, infinity when the loop mode is on, in which case 
“Loop Infinite” would be displayed, and any other positive integer number in between, which can 
be specified with a client command. 
 
3.3.2.12 Absolute Position 
 
The twelfth column, entitled “Abs Position”, displays the amount of elapsed time since the point in 
time when the signal was most recently directed to start Playing at time zero on that source. 
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3.3.2.13 Loop Position 
 
The thirteenth column, entitled “Loop Pos”, displays the amount of elapsed time since the point in 
time when the Playing signal was most recently looped back to the beginning of the signal stored 
in memory, which is considered to be time zero. 
 
3.3.2.14 Loop Number 
 
The fourteenth column, entitled “Loop Num”, displays the number of loop iterations that have 
occurred on that sound source since the point in time when the signal was most recently directed 
to Play in loop mode on that source. 
 
3.3.2.15 Update 
 
The fifteenth column, entitled “Update”, displays the frequency in times per second with which the 
location of the source is updated via client update commands and/or server side tracking. 
 
3.3.2.16 Level 
 
The sixteenth column, entitled “Level”, displays the amplitude level of the assigned audio input 
signal after leaving Input Model processing but before entering Path Model processing. 
 
3.3.2.17 Skipped 
 
The seventeenth column, entitled “Skipped”, displays the number of blocks of samples of audio 
input signal which are “missing” and assumed by the GoldServ engine to have been skipped by 
the application supplying the signal.  This typically would involve a stream-from-disk capability.   
 
This field differs from the Skipped Buffers Counter in the status bar at the bottom of the window, 
as that counter is tallying skips in the GoldServ output signal rather than an input signal. 
 
3.3.2.18 Interpolation 
 
The eighteenth column, entitled “Interp”, displays the type of interpolator used when extracting 
data from the absolute delay line.  Its specific values can be one of the following methods: 
 

o “None” – no interpolation is performed 
o “Linear” – linear interpolation is performed 
o “DynamicPoly” – Dynamic Polyphase* interpolation is performed 

 
*Dynamic Polyphase is a very sophisticated higher-order interpolator which has been optimized 
for the processor.  It can be described as an “ideal lowpass filter with Kaiser window applied”.  It 
is dynamic in that it varies with the distance, speed, and acceleration of the sound source. 
 
3.3.2.19 Delay Line Length 
 
The nineteenth column, entitled “Delay Line Len”, displays 3 pieces of information related to the 
delay line.  It first displays the number of items in position delay line, followed by a hyphen, 
whether or not position interpolation currently occurs (“Interp” / “No Interp”), followed by a 
semicolon, and finally the length of the delay line in seconds (e.g. “max 1.1 sec”). 
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3.3.3 Input Audio Signal Panel 
 
The bottom panel on the Main View is the “Input Audio Signal Panel”.  Each row in the table 
corresponds to an input audio signal coming into the acoustic simulation, and each of the 12 
columns in the table represents a field of data pertaining to those signals – see Figure 32 below.   
 

 
Figure 32 - The Input Audio Signal Panel Fields 

 
The following subsections describe each of these fields and the information each provides about 
the input audio signals.   
 
3.3.3.1 Short Name 
 
The first column, entitled “Short Name”, displays the name of the input audio signal described by 
the remaining fields.  For a wave file, this will be the file name without the full directory path or file 
extension.  For a physical input channel, this will be the physical device description, such as 
“Channel Manager Input” when the AuSIM Channel Manager is used, “ASIO Input” when ASIO 
hardware is in use and being polled for data directly, etc. 
 
3.3.3.2 Full Name 
 
The second column, entitled “Full Name”, displays the full name of the input audio signal 
described by the remaining fields.  For a wave file, this will be the file name including the full 
directory path and file extension.  For a physical input channel, this will be the physical device 
description, such as “Channel Manager Input” when the AuSIM Channel Manager is used, “ASIO 
Input” when ASIO hardware is in use and being polled for data directly, etc. 
 
3.3.3.3 Channels 
 
The third column, entitled “Channels”, displays the number of independent channels present in a 
signal.  For a mono wave file, for example, there would be one channel.  For a stereo wave file 
(more common), there would be two channels.  It is also possible to have wave files with more 
than two channels.  For physical input signals, there are commonly 8, 16, or 24 ADAT channels 
and often two more SPIDF channels, for a total of 10, 18, or 26.  Use of the Channel Manager as 
an intermediary to the input/output ports allows for these numbers to be further limited to the 
known maximum number of signals that will be used, which can further optimize system operation 
and maximize processing capacity. 
 
3.3.3.4 Sample Rate 
 
The fourth column, entitled “Sample Rate”, displays the number of audio samples per second (in 
Hz) that are being produced by the signal.   
 
3.3.3.5 Sample Type 
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The fifth column, entitled “Sample Type”, reports the quality of the sample being provided by the 
signal, e.g. “32f” specifies a 32-bit floating-point sample, while “16s” specifies a 16-bit integer.   
 
3.3.3.6 Length 
 
The sixth column, entitled “Length”, reports the length of the signal source.  For a wave file, this 
value is the length of the wave file in seconds or minutes/seconds.  For a live input channel, this 
value is infinity. 
 
3.3.3.7 Number of Readers 
 
The seventh column, entitled “Num Readers”, reports the number of sound sources to which the 
signal has been assigned and which are actively playing the signal. 
 
3.3.3.8 Number of WavFt’s 
 
The eighth column, entitled “Num WavFt”, reports the total number of sound sources to which the 
signal has been assigned via cre_open_wave, regardless of how many of them are actively 
playing the signal.  (“WavFt” refers to a data structure which represents a waveform, which is 
used by the cre_tron API.) 
 
3.3.3.9 WavFt Channels 
 
The ninth column, entitled “WavFt Channels”, reports how many of the signal’s channels are 
being played by at least one sound source.  (“WavFt” refers to a data structure which represents 
a waveform, which is used by the cre_tron API.) 
 
3.3.3.10 WavFt Persistance 
 
The tenth column, entitled “WavFt Channels”, indicates whether or not the WavFt structure and 
the data contained therein will persist through a cre_close call and still be available after the next 
cre_init.  A value of FALSE indicates the WavFt structure will no longer have valid data after 
cre_close, while a value of TRUE indicates that the data in the WavFt structure will continue to 
have valid data after a cre_close and a subsequent cre_init. 
 
3.3.3.11 WavFt Interpolation 
 
The eleventh column, entitled “WavFt Interp”, indicates the quality of the interpolator used (if 
needed) to resample a signal from its native sample rate to the sample rate used by the 
GoldServ’s DSP engine.  The default value is “FixedPoly” which has been determined to be the 
best possible choice for the current implementation, but this interpolation method can be modified 
by a client to a lower-quality interpolator such as “Linear” if it wishes to do so to conserve 
processing resources for other priorities.  Since this interpolation is real-time, it has a significant 
impact on overall system performance. 
 
3.3.3.12 Create String 
 
The twelfth column, entitled “Create Str”, displays a string of all the signal parameters, including 
parameter names and their values, stored in the WavFt data structure, including: 
 

• Wave File Name 
• Sample Rate 
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• Loop Spec Count 
• Loop Spec Start Time in Microseconds 
• Loop Spec End Time in Microseconds 
• Persistence 
• Interpolation Type 
• Interpolation Quality 

 
3.4 Path View Panels 
 
The “Path View” can be selected from the “View” menu or by using the third toolbar button from 
the left, and it also consists of three panels or tables of data – see Figure 33 below.  The “Path 
Panel” is the top-most panel or table; the “Location Panel” is the middle panel, and the “Model 
Panel” is the bottom panel.   
 

 
Figure 33 - The Path View 

 
The following subsections describe the information displayed by each panel. 
 
3.4.1 Path Panel 
 
The top panel on the “Path View” is the “Path Panel”.  Each row in the table corresponds to an 
audio propagation path from a sound source to a listener in the acoustic simulation.  Thus, the 
number of paths displayed will be equal to the number of sound sources defined multiplied by the 
number of listeners defined.  Each of the 13 columns in the table represents a field of data 
pertaining to one of those paths from a source to a listener – see Figure 34 below.   
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Figure 34 - The Path Panel Fields 

 
The following subsections describe each of these fields and the information each provides about 
the audio propagation paths.   
 
3.4.1.1 Path ID 
 
The first column, entitled “Path ID”, displays an index integer number that uniquely identifies each 
unique audio propagation path, which can also be thought of as source-listener combinations.  
Thus, the number of paths displayed will be equal to the number of sound sources defined 
multiplied by the number of listeners defined.  The serial numbering is zero-based, so the first 
path index number will be “0”, the second path index number will be “1”, etc.   
 
3.4.1.2 Signal 
 
The second column, entitled “Signal”, displays the name of the input audio signal assigned to the 
source in the selected path.  For a wave file, this will be the file name without the full directory 
path or file extension.  For a physical input channel, this will be the physical device description, 
such as “Channel Manager Input” when the AuSIM Channel Manager is used, “ASIO Input” when 
ASIO hardware is in use and being polled for data directly, etc. 
 
3.4.1.3 Gain Left 
 
The third column, entitled “Gain Left”, displays the sum of the left-ear-channel gains from the 
following Models: Source, Environment, Material, Path, and Listener.  Positive quantities 
represent true gain, while negative values represent attenuation.  The units displayed are 
decibels by default, but the display can be changed to linear units or meters by selecting one of 
these options from the “Format” menu.   
 
3.4.1.4 Gain Right 
 
The third column, entitled “Gain Right”, displays the sum of the right-ear-channel gains from the 
following Models: Source, Environment, Material, Path, and Listener.  Positive quantities 
represent true gain, while negative values represent attenuation.  The units displayed are 
decibels by default, but the display can be changed to linear units or meters by selecting one of 
these options from the “Format” menu. 
 
3.4.1.5 Time Delay Left 
 
The fifth column, entitled “Time Delay L”, displays the sum of the left-ear-channel time delays 
from the following Models: Source, Environment, Material, Path, and Listener.  Because overall 
time delays are calculated according to a fixed reference point on the head, the Listener Model 
time delay to may be less for propagation to a nearer ear and display as a negative value, or be 
positive if the ear is further than the reference point. 
 
3.4.1.6 Time Delay Right 
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The sixth column, entitled “Time Delay R”, displays the sum of the right-ear-channel time delays 
from the following Models: Source, Environment, Material, Path, and Listener.  Because overall 
time delays are calculated according to a fixed reference point on the head, the Listener Model 
time delay to may be less for propagation to a nearer ear and display as a negative value, or be 
positive if the ear is further than the reference point. 
 
3.4.1.7 ITD 
 
The seventh column, entitled “Time Delay R”, displays the interaural time delay or ITD, which is 
defined to be the difference in time delay between when a signal reaches the left and right ears of 
a listener.  In this implementation, it is calculated to be the difference between “Time Delay L” and 
“Time Delay R”.   
 
3.4.1.8 Time Origin 
 
The eighth column, entitled “Time Origin”, displays the amount of time passed in seconds or 
minutes/seconds since the current acoustic simulation began.  The format for the display of this 
field can be modified by selecting one of the ”Time” options on the “Format” menu. 
 
3.4.1.9 Pre Level 
 
The ninth column, entitled “Pre Level”, displays the signal level of the audio traversing the 
propagation path from the source to the listener before any of the model filters or gains are 
applied to it.  The units displayed are decibels by default, but the display can be changed to linear 
units or meters by selecting one of these options from the “Format” menu. 
 
3.4.1.10 Filter Level, Left Channel 
 
The tenth column, entitled “Filter Level L”, displays the signal level of the audio traversing the 
propagation path from the source to the left ear of the listener after the Source, Environment, 
Material, Path, and Listener model filters have been applied, but before any of these model gains 
are applied to it.  The units displayed are decibels by default, but the display can be changed to 
linear units or meters by selecting one of these options from the “Format” menu. 
 
3.4.1.11 Filter Level, Right Channel 
 
The eleventh column, entitled “Filter Level R”, displays the signal level of the audio traversing the 
propagation path from the source to the right ear of the listener after the Source, Environment, 
Material, Path, and Listener model filters have been applied, but before any of these model gains 
are applied to it.  The units displayed are decibels by default, but the display can be changed to 
linear units or meters by selecting one of these options from the “Format” menu. 
 
3.4.1.12 Post Level, Left Channel 
 
The twelfth column, entitled “Post Level L”, displays the signal level of the audio traversing the 
propagation path from the source to the left ear of the listener after the Source, Environment, 
Material, Path, and Listener model filters and gains have been applied to it.  The units displayed 
are decibels by default, but the display can be changed to linear units or meters by selecting one 
of these options from the “Format” menu. 
 
3.4.1.13 Post Level, Right Channel 
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The thirteenth column, entitled “Post Level R”, displays the signal level of the audio traversing the 
propagation path from the source to the right ear of the listener after the Source, Environment, 
Material, Path, and Listener model filters and gains have been applied to it.  The units displayed 
are decibels by default, but the display can be changed to linear units or meters by selecting one 
of these options from the “Format” menu. 
 
3.4.2 Location (Path-specific) Panel 
 
The middle panel on the “Path View” is the “Location Panel”.  This table of data displays location 
information pertaining to whichever path in the above table has been selected/highlighted with the 
mouse or pointing device.   Each row in the table corresponds to a specific 3D location, vector, or 
scalar value that is unique to a path, and provides orientation of the associated acoustic object 
when applicable – see Figure 35 below.  The acoustic object could be a listener, a sound source, 
or something in the acoustic environment that affects how the audio sounds. 
 
The acoustic simulation 3D locations listed on this panel for the selected path are:  
 

• Head Center 
• Direct Source 
• Virtual Source 
• Left Ear 
• Right Ear 

 
The 3D vectors listed on this panel for the selected path are:  
 

• Source in Listener Coordinates 
• Source in Listener Polar Coordinates 
• Head Center to Source 
• Left Ear to Source 
• Right Ear to Source 
• Head Center to Virtual Source 
• Left Ear to Virtual Source 
• Right Ear to Virtual Source 

 
The scalar values listed on this panel for the selected path are:  
 

• Interaural Distance 
• Direct Path Length, to Head Center 
• Direct Path Length, to Left Ear 
• Direct Path Length, to Right Ear 
• Virtual Path Length, to Head Center 
• Virtual Path Length, to Left Ear 
• Virtual Path Length, to Right Ear 
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Figure 35 - The Location Panel Fields 

 
The following subsections describe each of these fields and the specific information each 
provides with respect to the selected path.   
 
3.4.2.1 Location 
 
The first column, entitled “Location”, displays the description of the location being described by 
the rest of the values in the table.  Each row corresponds to a specific 3D location, vector, or 
scalar value that is unique to a path, and provides orientation of the associated acoustic object 
when applicable.  The remaining columns in the table provide the numeric values corresponding 
to the description found in the “Location” column. 
 
3.4.2.2 X 
 
The second column, entitled “X”, displays the X-coordinate (in Cartesian coordinates) of each 
path-related location, using the same acoustic simulation axes system described for the Listener 
and Sound Sources.  Also, this column displays the X-component of the vector when 3D vector 
parameters are listed and the scalar value when scalar values are listed. 
 
The units of the coordinate system in use are listed next to the coordinate; the default unit is 
centimeters (cm), but other units that the client may specify for use include inches (in), feet (ft), 
meters (m), and millimeters (mm).   
 
3.4.2.3 Y 
 
The third column, entitled “Y”, displays the Y-coordinate (in Cartesian coordinates) of each path-
related location, using the same acoustic simulation axes system described for the Listener and 
Sound Sources.  Also, this column displays the Y-component of the vector when 3D vector 
parameters are listed. 
 
The units of the coordinate system in use are listed next to the coordinate; the default unit is 
centimeters (cm), but other units that the client may specify for use include inches (in), feet (ft), 
meters (m), and millimeters (mm).   
 
3.4.2.4 Z 
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The fourth column, entitled “Z”, displays the Z-coordinate (in Cartesian coordinates) of each path-
related location, using the same acoustic simulation axes system described for the Listener and 
Sound Sources.  Also, this column displays the Z-component of the vector when 3D vector 
parameters are listed. 
 
The units of the coordinate system in use are listed next to the coordinate; the default unit is 
centimeters (cm), but other units that the client may specify for use include inches (in), feet (ft), 
meters (m), and millimeters (mm).   
 
3.4.2.5 Yaw 
 
The fifth column, entitled “Yaw”, displays an orientation angle for the path locations which are part 
of the source or listener definitions.  The Listener Yaw is displayed for path locations directly 
linked to the listener, such as head center and ear locations, while the Source Yaw is displayed 
for path locations directly linked to the source.  No Yaw values are displayed for the vector and 
scalar parameters listed. 
 
The default units used by the client and displayed by the GoldServ monitor are degrees, but the 
display can be changed to radians by selecting “Angle Radians” from the “Format” menu. 
 
3.4.2.6 Pitch 
 
The sixth column, entitled “Pitch”, displays an orientation angle for the path locations which are 
part of the source or listener definitions.  The Listener Pitch is displayed for path locations directly 
linked to the listener, such as head center and ear locations, while the Source Pitch is displayed 
for path locations directly linked to the source.  No Pitch values are displayed for the vector and 
scalar parameters listed. 
 
The default units used by the client and displayed by the GoldServ monitor are degrees, but the 
display can be changed to radians by selecting “Angle Radians” from the “Format” menu. 
 
3.4.2.7 Roll 
 
The seventh column, entitled “Roll”, displays an orientation angle for the path locations which are 
part of the source or listener definitions.  The Listener Roll is displayed for path locations directly 
linked to the listener, such as head center and ear locations, while the Source Roll is displayed 
for path locations directly linked to the source.  No Roll values are displayed for the vector and 
scalar parameters listed. 
 
The default units used by the client and displayed by the GoldServ monitor are degrees, but the 
display can be changed to radians by selecting “Angle Radians” from the “Format” menu. 
 
3.4.3 Model (Path-specific) Panel 
 
The bottom panel on the “Path View” is the “Model Panel”.  This table of data also displays 
information pertaining to whichever path in the above table has been selected/highlighted with the 
mouse or pointing device.   Each row in the table corresponds to a mathematical Model that is 
used to filter audio traveling along the virtual propagation path, to re-create the changes the audio 
would undergo if it were traveling naturally through a real or artificial environment.  The Models 
used by the simulation are listed in the order they are used for processing, which is: 
 

1. Input 
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2. Source 
3. Environment 
4. Path 
5. Material 
6. Listener 
7. Output 

 
Each of the 13 columns in the table represents a field of data pertaining to one of those Models 
for the selected path from a source to a listener – see Figure 36 below.   
 

 
Figure 36 - The Model Panel Fields 

 
The following subsections describe each of these fields and the specific information each 
provides about the Model used. 
 
3.4.3.1 Model Type 
 
The first column, entitled “Model Type”, displays the model types listed in the list above. 
 
3.4.3.2 Model Name 
 
The second column, entitled “Model Name”, displays the name of the model.  If the model is one 
of the default models built-in by AuSIM, the name of the model will begin with the string “AuSIM”.  
If the model has been defined and plugged-in by the end user, the name will be the one specified 
by the client programmer. 
 
3.4.3.3 Global Enable 
 
The third column, entitled “Global Enable”, displays the simulation-wide state of enabledness of 
the Gain, Filter, and Delay processing.  The default value of the character string displayed is 
“Gain Filter Delay”, which indicates processing is globally enabled for all three.  If one or more of 
these key words is missing from the display, this indicates that the missing processing has been 
globally disabled. 
  
3.4.3.4 Model Enable 
 
The fourth column, entitled “Model Enable”, displays the model-specific state of enabledness of 
the Gain, Filter, and Delay processing.  The default value of the character string displayed is 
“Gain Filter Delay”, which indicates processing is enabled for all three for this model.  If one or 
more of these key words is missing from the display, this indicates that the missing process has 
been disabled for this model. 
 
3.4.3.5 Gain, Left Channel 
 
The fifth column, entitled “Gain L”, displays the quantity of signal Gain introduced by each model, 
when performing model processing for the left-ear channel.  Positive quantities represent true 
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gain, while negative values represent attenuation.  The default units are decibels, but the display 
units can be changed by selected any of the last three options on the “Format” menu: “db”, 
“Linear”, or “Meters”. 
 
3.4.3.6 Gain, Right Channel 
 
The sixth column, entitled “Gain R”, displays the quantity of signal Gain introduced by each 
model, when performing model processing for the right-ear channel.  Positive quantities represent 
true gain, while negative values represent attenuation.  The default units are decibels, but the 
display units can be changed by selected any of the last three options on the “Format” menu: 
“db”, “Linear”, or “Meters”. 
 
3.4.3.7 Delay, Left Channel 
 
The seventh column, entitled “Delay L”, displays the quantity of signal time delay introduced by 
each model, when performing model processing for the left-ear channel.  Possible units of time 
displayed include microseconds, seconds, or seconds/minutes.  The format for the display of this 
field can be modified by selecting one of the ”Time” options on the “Format” menu. 
 
3.4.3.8 Delay, Right Channel 
 
The eighth column, entitled “Delay R”, displays the quantity of signal time delay introduced by 
each model, when performing model processing for the right-ear channel.  Possible units of time 
displayed include microseconds, seconds, or seconds/minutes.  The format for the display of this 
field can be modified by selecting one of the ”Time” options on the “Format” menu. 
 
3.4.3.9 Filters 
 
The ninth column, entitled “FIlters”, displays information describing the filter used by the model.  
Possible information includes the type of filter (FIR, IIR, etc.), how many coefficients used by the 
filter (also referred to as its “length”), and the portion of the filter activated by the selected path 
(i.e. signal arrival direction for AHM filters).   
 
3.4.3.10 Integer Attributes 
 
The tenth column, entitled “Integer Attributes”, displays a list of the names and current values of 
all the integer-type model attributes, concatenated into a single character string.  Each list is 
unique to the model it represents.  A blank field value indicates there are no integer-type 
attributes for this model. 
 
3.4.3.11 Double Attributes 
 
The eleventh column, entitled “Double Attributes”, displays a list of the names and current values 
of all the double-precision-type model attributes, concatenated into a single character string.  
Each list is unique to the model it represents.  A blank field value indicates there are no double-
precision-type attributes for this model. 
 
3.4.3.12 Double Array Attributes 
 
The twelfth column, entitled “Double Array Attrs”, displays a list of the names and current values 
of all the double-precision-array-type model attributes, concatenated into a single character 
string.  Each list is unique to the model it represents.  A blank field value indicates there are no 



 

 Page 40 

double-precision-array-type attributes for this model.  An empty array indicates that the attribute 
exists, but that no values have yet been defined for the array. 
 
3.4.3.13 String Attributes 
 
The thirteenth column, entitled “String Attributes”, displays a list of the names and current values 
of all the character-string-type model attributes, concatenated into a single character string.  Each 
list is unique to the model it represents.  A blank field value indicates there are no character- 
string-type attributes for this model.  A blank value indicates that the attribute exists, but that no 
values have yet been defined for the character string. 
 
3.5 Event View Panels 
 
The “Event View” can be selected from the “View” menu or by using the fourth toolbar button from 
the left, and it consists of only two panels or tables of data – see Figure 37 below.  The “Clock 
Panel” is the top-most panel or table, and the “Event Panel” is the bottom panel.   
 

 
Figure 37 - The Events View 

 
The following subsections describe the information displayed by each panel. 
 
3.5.1 Clock Panel 
 
The top panel on the “Event View” is the “Clock Panel”.  Each row in the table represents a 
“clock” or list of acoustic events that are scheduled to occur at a specified time.  Each of the 6 
columns in the table represents a field of data pertaining to one of those clocks or timelines – see 
Figure 38 below.   
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Figure 38 - The Clock Panel Fields 

 
The following subsections describe each of these fields and the specific information each 
provides about the clock. 
 
3.5.1.1 Clock 
The first column, entitled “Clock”, displays an index integer number that uniquely identifies each 
sound source.  The serial numbering is zero-based, so the first sound source will be “0”, the 
second sound source will be “1”, etc.  This identifying number, also sometimes referred to as the 
“Clock ID”, is used to identify the source when calls to the cre_tron API are made. 
 
3.5.1.2 Current Time 
 
The second column, entitled “Current Time”, displays a pointer to the current point in time on the 
clock’s timeline. 
 
3.5.1.3 Number of Events 
 
The third column, entitled “Num Events”, displays a count of the total number of absolute events 
defined for the clock or event list.  An absolute event is defined to be an audio event which has 
been assigned a specific, absolute time on the clock’s timeline.  Such events will also be the ones 
displayed on the Event Panel below. 
 
3.5.1.4 Relative Queue 
 
The fourth column, entitled “Relative Queue”, displays a count of the total number of relative 
events that have been added to a queue, and which are waiting to be added to an event list upon 
the next call to cre_set_events or cre_update_audio.  A relative event is defined to be an audio 
event which will be executed a specified amount of time after the next execution of a call to 
cre_set_events or cre_update_audio.  Such events will NOT be displayed on the Event Panel 
below. 
 
3.5.1.5 Immediate Queue 
 
The fifth column, entitled “Immediate Queue”, displays a count of the total number of immediate 
events that have been added to a queue, and which are waiting to be added to an event list upon 
the next call to cre_set_events or cre_update_audio.  An immediate event is defined to be an 
audio event which will be executed immediately upon the next execution of a call to 
cre_set_events or cre_update_audio.  Such events will NOT be displayed on the Event Panel 
below. 
 
3.5.1.6 Running 
 
The sixth column, entitled “Running”, displays a status word indicating whether or not a clock 
timeline or event list is actively being executed.  The field will display “Playing” if so, “Paused” if 
not. 
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3.5.2 Events Panel 
 
The bottom panel on the “Event View” is the “Events Panel”.  This table of data also displays a list 
of acoustic events that have been scheduled on the clock’s timelines.  Possible types of events 
include a change in play state of a sound source, a change in position of a sound source or 
listener, etc.  The time the event will occur, the nature of the event, and which acoustic object will 
be responsible for the event are listed in this table – see Figure 39 below. 
 

 
Figure 39 - The Events Panel Fields 

The following subsections describe each of these fields and the specific information each 
provides about the events associated to the selected clock. 
 
3.5.2.1 Event Time 
 
The first column, entitled “Event Time”, displays the point in time at which the audio event is 
scheduled to be executed. 
 
3.5.2.2 Event Type 
 
The second column, entitled “Event Type”, displays the type or nature of the event on the list.  
Possible types of events include a change in play state of a sound source, a change in position of 
a sound source or listener, etc. 
 
3.5.2.3 Object ID 
 
The third column, entitled “Object ID”, displays an index integer number that uniquely identifies 
each acoustic object in the acoustic environment.  The serial numbering is zero-based, so the first 
object will be “0”, the second will be “1”, etc.  This object could be a listener, a sound source, or 
something in the acoustic environment that affects how the audio sounds. 
 
3.5.2.4 Object Name 
 
The fourth column, entitled “Object ID”, displays the specific name of the object that the event is 
operating on.  This object could be a listener, a sound source, or something in the acoustic 
environment that affects how the audio sounds. 
 
3.5.2.5 Argument 1 
 
The fifth column, entitled “Argument 1”, displays event attribute data set by the client.  It could be 
anything, depending on the application. 
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3.5.2.6 Argument 2 
 
The sixth column, entitled “Argument 2”, also displays application-specific event attribute data 
determined by the client. 
 
3.6 Status Bar Fields 
 
The GoldServ application monitor also displays a status bar at the very bottom of the window – 
see Figure 6 above.  It contains seven separate fields which show continually updated status for 
various measures of GoldServ operation.  The first area displays a context-sensitive message, 
the next two report buffer overflows and clock time elapsed, and the remaining fields report the 
rate of each transport mechanism throughput. 
 
3.6.1 Status Message 
 
The status message area of the Status Bar is the left-most field on the status bar – see Figure 40 
below.  A short context-sensitive message is displayed here when the mouse or pointing device 
arrow is placed over a toolbar button or menu item.  The message is a short description of the 
function of the button or menu item.  (When the pointing device is not pointing to a button or 
menu item, the default Windows status message is “For help, press F1”; however, pressing F1 
does not display any further help at this time.) 
 

 
Figure 40 - The Status Message Area 

 
3.6.2 Skipped Buffers Counter 
 
To the immediate right of the message section is a field that displays a continuously updated 
counter of how many digital audio input channel data buffers have been skipped – see Figure 41 
below.  Audio buffers can be skipped when the load placed on the system by client commands is 
momentarily greater than the system capacity, so these occurrences are counted and displayed 
on the status bar.  The rate at which the number of skipped buffers is increasing is a proportional 
measure of audio degradation due to inadequate system processing capacity.  This counter can 
be reset to zero with a click of the appropriate menu item or tool bar button, which forces the tally 
to include only subsequently skipped buffer occurrences. 
 

 
Figure 41 – The Skipped Buffers Counter 

 
3.6.3 Clock 
 
To the immediate right of the skipped buffers counter section is a field that displays a clock, or, 
more accurately, a time counter that starts at zero when a simulation starts and keeps track of 
how long the simulation has been running – see Figure 42 below. 
 

 
Figure 42 – The Clock or Time Counter 
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3.6.4 RS-232 Serial Port Transport Mechanism 
 
To the immediate right of the clock/time counter section is a field that displays data throughput 
rates for the connected serial port connection.  Rates for both incoming data as well as outgoing 
data are showed, represented as a percentage of the maximum capacity – see Figure 43 below. 
 

 
Figure 43 - The Serial Port Throughput Display 

 
3.6.5 RPC Ethernet Transport Mechanism 
 
To the immediate right of the RS-232 serial port display section is a field that displays data 
throughput rates for the RPC-protocol connection.  Rates for both incoming data as well as 
outgoing data are showed, represented with a number of cre_tron function calls (In) or data items 
returned to cre_tron function calls (Out) per second – see Figure 44 below. 
 

 
Figure 44 - The RPC Ethernet Throughput Display 

 
3.6.6 USB 2.0 Transport Mechanism  
 
To the immediate right of the RPC throughput display section is a field that displays data 
throughput rates for the USB connection, if one exists.  Rates for both incoming data as well as 
outgoing data are showed, represented with a number of cre_tron function calls (In) or data items 
returned to cre_tron function calls (Out) per second.  However, if no USB PCI hardware device is 
installed in the GoldServ system, this display area will remain blank – see Figure 45 below. 
 

 
Figure 45 - The USB 2.0 Throughput Display 

 
3.6.7 TCP Ethernet Transport Mechanism 
 
To the immediate right of the USB throughput display section is a field that displays data 
throughput rates for the TCP-protocol connection.  Rates for both incoming data as well as 
outgoing data are showed, represented with a number of cre_tron function calls (In) or data items 
returned to cre_tron function calls (Out) per second – see Figure 46 below. 
 

 
Figure 46 - The TCP Ethernet Throughput Display 


